WP before start maske sure that you have PHP version or greater recomm

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
WP:
- before start maske sure that you have:
* PHP version 5.2.4 or greater (recommended: PHP 5.4 or greater)
* MySQL version 5.0 or greater (recommended: MySQL 5.5 or greater)
- download wordpress project from https://jshakyawar@bitbucket.org/jshakyawar/treatmewordpress.git
if you haven't already.
- create a database for WordPressApp, as well as a MySQL user who has all privileges for accessing and modifying it.
- add to wp-config.php your database information.
- move the WordPressApp files to the your web server:
* if you want to integrate WordPress into the root of your domain (e.g. http://example.com/), move or upload all contents of the unzipped WordPress directory (excluding the WordPress directory itself) into the root directory of your web server.
* if you want to have your WordPress installation in its own subdirectory on your website (e.g. http://example.com/blog/), create the blog directory on your server and upload the contents of the unzipped WordPress package to the directory via FTP.
(!) Note: If your FTP client has an option to convert file names to lower case, make sure it's disabled.
- run the WordPressAPP by accessing the URL in a web browser.
- if you moved WordPressApp in the root directory, you should visit: http://example.com/
- if you moved WordPressApp in subdirectory called somefolder, for example, you should visit: http://example.com/somefolder/
MEAN:
- make sure that you have already installed: git, node, npm, mongodb
- clone this repo: https://github.com/chouhanv/treatme
- in your terminal run "npm install" to get all dependencies
- start your mongo database
- after that run app by command "node treatme.js" or "PORT=your_port node treatme.js" if you want different port other than 8080
- then, load http://localhost:8080 or http://localhost:your_port in a browser to see the output