НаКлиенте Процедура ТоварыСрокГодностиНа чалоВыбора Элемент ДанныеВыбо

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
&НаКлиенте
Процедура ТоварыСрокГодностиНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Элемент.СписокВыбора.Очистить();
МассивСрокиГодности = ПолучитьСписокСроковГодностиНоменклатуры(Элементы.Товары.ТекущиеДанные.Номенклатура, Элементы.Товары.ТекущиеДанные.Серия);
Для Каждого СрокГодности Из МассивСрокиГодности Цикл
Элемент.СписокВыбора.Добавить(СрокГодности);
КонецЦикла;
КонецПроцедуры
&НаСервере
Функция ПолучитьСписокСроковГодностиНоменклатуры(Номенклатура, Серия)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ОстаткиНоменклатурыОстатки.СрокГодности
|ИЗ
| РегистрНакопления.ОстаткиНоменклатуры.Остатки(
| &ДатаДокумента,
| Склад = &Склад
| И Серия = &Серия
| И Номенклатура = &Номенклатура
| И СрокГодности <> ДАТАВРЕМЯ(1,1,1)) КАК ОстаткиНоменклатурыОстатки";
Запрос.УстановитьПараметр("ДатаДокумента", Объект.Дата);
Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
Запрос.УстановитьПараметр("Серия", Серия);
Запрос.УстановитьПараметр("Склад", Объект.Склад);
ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();
МассивСроковГодности = Новый Массив;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
МассивСроковГодности.Добавить(ВыборкаДетальныеЗаписи.СрокГодности);
КонецЦикла;
Возврат МассивСроковГодности;
КонецФункции
&НаКлиенте
Процедура ТоварыНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Элемент.СписокВыбора.Очистить();
МассивНоменклатура = ПолучитьСписокНоменклатуры();
Для Каждого Номенклатура Из МассивНоменклатура Цикл
Элемент.СписокВыбора.Добавить(Номенклатура);
КонецЦикла;
КонецПроцедуры
&НаСервере
Функция ПолучитьСписокНоменклатуры()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ОстаткиНоменклатурыОстатки.Номенклатура
|ИЗ
| РегистрНакопления.ОстаткиНоменклатуры.Остатки() КАК ОстаткиНоменклатурыОстатки";
ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();
МассивСроковГодности = Новый Массив;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
МассивСроковГодности.Добавить(ВыборкаДетальныеЗаписи.Номенклатура);
КонецЦикла;
Возврат МассивСроковГодности;
КонецФункции