НаКлиенте Процедура ТоварыНоменклатураНа чалоВыбора Элемент ДанныеВыбо

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
&НаКлиенте
Процедура ТоварыНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Элемент.СписокВыбора.Очистить();
МассивНоменклатура = ПолучитьСписокНоменклатуры();
Для Каждого Номенклатура Из МассивНоменклатура Цикл
Элемент.СписокВыбора.Добавить(Номенклатура);
КонецЦикла;
КонецПроцедуры
&НаСервере
Функция ПолучитьСписокНоменклатуры()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ОстаткиНоменклатурыОстатки.Номенклатура
|ИЗ
| РегистрНакопления.ОстаткиНоменклатуры.Остатки() КАК ОстаткиНоменклатурыОстатки";
ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();
МассивСроковГодности = Новый Массив;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
МассивСроковГодности.Добавить(ВыборкаДетальныеЗаписи.Номенклатура);
КонецЦикла;
Возврат МассивСроковГодности;
КонецФункции