Перем мДатаРассчитанныхИто гов Перем мАктивирован Процедура Запуск Соо

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
Перем мДатаРассчитанныхИтогов;
Перем мАктивирован;
Процедура Запуск()
Сообщить("Начало проведения: "+ТекущаяДата(),СтатусСообщения.Информация);
Если ТабличноеПолеВидыОбъектов.Количество()>0 Тогда
СписокРазрешенныхДокументов = ТабличноеПолеВидыОбъектов ;
Иначе
СписокРазрешенныхДокументов = Неопределено;
КонецЕсли;
Если ВыборОрганизации = 0 Тогда
СписокДокументов = ПерепроведениеДокументов(НачПериода, КонПериода,,ОтменятьПроведение,ИсключитьОбщии,СписокРазрешенныхДокументов);
Иначе
Если СписокОрганизаций.Количество() > 0 Тогда
СписокДокументов = ПерепроведениеДокументов(НачПериода, КонПериода, СписокОрганизаций.ВыгрузитьКолонку("Организация"),ОтменятьПроведение,ИсключитьОбщии,СписокРазрешенныхДокументов);
КонецЕсли;
КонецЕсли;
Сообщить("Конец проведения: "+ТекущаяДата(),СтатусСообщения.Информация);
КонецПроцедуры
Процедура КнопкаВыполнитьНажатие(Кнопка)
Запуск();
КонецПроцедуры
Процедура ПоВсемОрганизациямПриИзменении(Элемент)
ДоступностьВыбораОрганизаций = (ВыборОрганизации = 1);
ЭлементыФормы.КоманднаяПанельСписокОрганизация.Доступность = ДоступностьВыбораОрганизаций;
ЭлементыФормы.СписокОрганизаций.Доступность = ДоступностьВыбораОрганизаций;
ЭлементыФормы.Панель1.Страницы.Организации.Доступность = ДоступностьВыбораОрганизаций;
Если НЕ ДоступностьВыбораОрганизаций Тогда
СписокОрганизаций.Очистить();
КонецЕсли;
КонецПроцедуры
Процедура ВыбПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачПериода = НастройкаПериода.ПолучитьДатуНачала();
КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры
Процедура СписокДокументовВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
Док = ВыбраннаяСтрока.Значение.ПолучитьФорму();
Док.Открыть();
КонецПроцедуры
Процедура ОтменятьПроведениеПриИзменении(Элемент)
Предупреждение("Внимание! Вы можете значительно изменить суммовой учет устанавливая данную опцию");
КонецПроцедуры
Процедура Активация()
// Активация таймера
//Сообщить("Активирован таймер отложенного запуска");
ЭтаФорма.ЭлементыФормы.Активация.Заголовок = "Отключить таймер";
ПодключитьОбработчикОжидания("ПопыткаАктивацииПроведения", 30);
мАктивирован = Истина;
ПопыткаАктивацииПроведения();
КонецПроцедуры
Процедура ДеАктивация()
// Активация таймера
//Сообщить("Деактивирован таймер отложенного запуска");
ЭтаФорма.ЭлементыФормы.НадписьТаймер.Заголовок = "";
ЭтаФорма.ЭлементыФормы.Активация.Заголовок = "Активировать таймер";
мАктивирован = Ложь;
ОтключитьОбработчикОжидания("ПопыткаАктивацииПроведения");
КонецПроцедуры
Процедура АктивацияНажатие(Элемент)
// Активация таймера
Если мАктивирован Тогда
ДеАктивация();
Иначе
Активация();
КонецЕсли;
КонецПроцедуры
Процедура ПопыткаАктивацииПроведения()
Если ТекущаяДата()>ДатаАктивации Тогда
ЭтаФорма.ЭлементыФормы.НадписьТаймер.Заголовок = "";
ДеАктивация();
Запуск();
Иначе
ЭтаФорма.ЭлементыФормы.НадписьТаймер.Заголовок = "Осталось:" + (ДатаАктивации-ТекущаяДата())+ " сек.";
КонецЕсли;
КонецПроцедуры
Процедура ОткрытьФормуВыбораТаблицы()
ФормаВыбораТаблицы = ПолучитьФорму("ФормаВыбораТаблицы",ЭтаФорма);
ФормаВыбораТаблицы.РежимВыбора = Истина;
ФормаВыбораТаблицы.СписокВыбранных.ЗагрузитьЗначения(ТабличноеПолеВидыОбъектов.ВыгрузитьКолонку("ИмяТаблицы"));
//ФормаВыбораТаблицы.ТипОбъекта = ТипОбъекта;
//ФормаВыбораТаблицы.ОбрабатыватьТабличныеЧасти = ОбрабатыватьТабличныеЧасти;
ФормаВыбораТаблицы.Открыть();
КонецПроцедуры // ()
Процедура ТабличноеПолеВидыОбъектовПередНачаломДобавления(Элемент, Отказ, Копирование)
ОткрытьФормуВыбораТаблицы();
Отказ = Истина;
КонецПроцедуры
Процедура ТабличноеПолеВидыОбъектовПередУдалением(Элемент, Отказ)
//Если Не ОчищатьРезультаты() Тогда
// Отказ = Истина;
//КонецЕсли;
КонецПроцедуры
Процедура ТабличноеПолеВидыОбъектовПослеУдаления(Элемент)
//Если ОчищатьРезультаты() Тогда
// ИнициализацияЗапроса();
//КонецЕсли;
КонецПроцедуры
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
ТабличноеПолеВидыОбъектов.Очистить();
Для каждого Значение Из ЗначениеВыбора Цикл
Строка = ТабличноеПолеВидыОбъектов.Добавить();
Строка.ИмяТаблицы = Значение.Значение;
Строка.ПредставлениеТаблицы = Значение.Представление;
КонецЦикла;
КонецПроцедуры
мАктивирован = Ложь;