Перем PCSC_Инфо Перем PCSC_Карта Перем PCSC_Наблюдение Перем PCSC_Захв

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
875
876
877
878
879
880
881
882
883
884
885
886
887
888
889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
911
912
913
914
915
916
917
918
919
920
921
922
923
924
925
926
927
928
929
930
931
932
933
934
935
936
937
938
939
940
941
942
943
944
945
946
947
948
949
950
951
952
953
954
955
956
957
958
959
960
961
962
963
964
965
Перем PCSC_Инфо;
Перем PCSC_Карта;
Перем PCSC_Наблюдение;
Перем PCSC_Захват;
Перем PCSC_Mifare;
Перем VARIANT_TRUE;
Перем VARIANT_FALSE;
Перем CL_KEYTYPE_MIFARE_A;
Перем CL_KEYTYPE_MIFARE_B;
Перем CL_CARDTYPE_UNKNOWN;
Перем CL_CARDTYPE_MIFARE_1K;
Перем CL_CARDTYPE_MIFARE_4K;
Перем CL_CARDTYPE_MIFARE_ULTRA_LIGHT;
Перем CL_CARDTYPE_SLE55R_XXXXX;
Перем CL_CARDTYPE_SR176;
Перем CL_CARDTYPE_SRIX4K;
Перем CL_CARDTYPE_AT88RF020;
Перем CL_CARDTYPE_AT88SC0204CRF;
Перем CL_CARDTYPE_AT88SC0808CRF;
Перем CL_CARDTYPE_AT88SC1616CRF;
Перем CL_CARDTYPE_AT88SC3216CRF;
Перем CL_CARDTYPE_AT88SC6416CRF;
Перем CL_CARDTYPE_SRF55V10P;
Перем CL_CARDTYPE_SRF55V02P;
Перем CL_CARDTYPE_SRF55V10S;
Перем CL_CARDTYPE_SRF55V02S;
Перем CL_CARDTYPE_TAGIT;
Перем CL_CARDTYPE_LRI512;
Перем CL_CARDTYPE_ICODESLI;
Перем CL_CARDTYPE_TEMPSENS;
Перем CL_CARDTYPE_ICODE1;
Перем CL_CARDTYPE_PICOPASS_2K;
Перем CL_CARDTYPE_PICOPASS_2KS;
Перем CL_CARDTYPE_PICOPASS_16K;
Перем CL_CARDTYPE_PICOPASS_16KS;
Перем Инициализирован;
Процедура УсловияДоступаДляDиVБлоков_ЗаполнитьСтроку(Строка, УД, Блоки)
Строка.Блоки = Блоки;
Строка.Биты = УД;
Если УД = 0 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "A или B";
Строка.Инкремент = "A или B";
Строка.Декремент = "A или B";
ИначеЕсли УД = 1 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "Никогда";
Строка.Инкремент = "Никогда";
Строка.Декремент = "A или B";
ИначеЕсли УД = 2 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "Никогда";
Строка.Инкремент = "Никогда";
Строка.Декремент = "Никогда";
ИначеЕсли УД = 3 Тогда
Строка.Чтение = "B";
Строка.Запись = "B";
Строка.Инкремент = "Никогда";
Строка.Декремент = "Никогда";
ИначеЕсли УД = 4 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "B";
Строка.Инкремент = "Никогда";
Строка.Декремент = "Никогда";
ИначеЕсли УД = 5 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "B";
Строка.Инкремент = "B";
Строка.Декремент = "A или B";
ИначеЕсли УД = 6 Тогда
Строка.Чтение = "A или B";
Строка.Запись = "B";
Строка.Инкремент = "B";
Строка.Декремент = "A или B";
ИначеЕсли УД = 7 Тогда
Строка.Чтение = "Никогда";
Строка.Запись = "Никогда";
Строка.Инкремент = "Никогда";
Строка.Декремент = "Никогда";
КонецЕсли;
КонецПроцедуры
Процедура УсловияДоступаДляTБлока_ЗаполнитьСтроку(Строка, УД, Блок)
Строка.Блоки = Блок;
Строка.Биты = УД;
Если УД = 0 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "A или B";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "Никогда";
Строка.КлючBЧтение = "A или B";
Строка.КлючBЗапись = "A или B";
ИначеЕсли УД = 1 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "A или B";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "A или B";
Строка.КлючBЧтение = "A или B";
Строка.КлючBЗапись = "A или B";
ИначеЕсли УД = 2 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "Никогда";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "Никогда";
Строка.КлючBЧтение = "A или B";
Строка.КлючBЗапись = "Никогда";
ИначеЕсли УД = 3 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "B";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "B";
Строка.КлючBЧтение = "Никогда";
Строка.КлючBЗапись = "B";
ИначеЕсли УД = 4 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "B";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "Никогда";
Строка.КлючBЧтение = "Никогда";
Строка.КлючBЗапись = "B";
ИначеЕсли УД = 5 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "Никогда";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "B";
Строка.КлючBЧтение = "Никогда";
Строка.КлючBЗапись = "Никогда";
ИначеЕсли УД = 6 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "Никогда";
Строка.УсловияЧтение = "A или B";
Строка.УсловиеЗапись = "Никогда";
Строка.КлючBЧтение = "Никогда";
Строка.КлючBЗапись = "Никогда";
ИначеЕсли УД = 7 Тогда
Строка.КлючAЧтение = "Никогда";
Строка.КлючAЗапись = "Никогда";
Строка.УсловияЧтение = "Никогда";
Строка.УсловиеЗапись = "Никогда";
Строка.КлючBЧтение = "Никогда";
Строка.КлючBЗапись = "Никогда";
КонецЕсли;
КонецПроцедуры
Процедура УсловияДоступаДляБлоков_Заполнить(УД_0, УД_1, УД_2, УД_3)
УсловияДоступаДляDиVБлоков.Очистить();
УсловияДоступаДляTБлока.Очистить();
УсловияДоступаДляDиVБлоков_ЗаполнитьСтроку(УсловияДоступаДляDиVБлоков.Добавить(), УД_0, "0 / 0..4");
УсловияДоступаДляDиVБлоков_ЗаполнитьСтроку(УсловияДоступаДляDиVБлоков.Добавить(), УД_1, "1 / 5..9");
УсловияДоступаДляDиVБлоков_ЗаполнитьСтроку(УсловияДоступаДляDиVБлоков.Добавить(), УД_2, "2 / 10..14");
УсловияДоступаДляTБлока_ЗаполнитьСтроку(УсловияДоступаДляTБлока.Добавить(), УД_3, "T-Блок");
КонецПроцедуры
Процедура ИнициализацияНажатие(Элемент)
PCSC_Инфо = Неопределено;
PCSC_Захват = Неопределено;
PCSC_Mifare = Неопределено;
Инициализирован = Ложь;
Попытка
ПодключитьВнешнююКомпоненту("AddIn.PCSCInfo");
ПодключитьВнешнююКомпоненту("AddIn.PCSCCapture");
ПодключитьВнешнююКомпоненту("AddIn.PCSCCard_Mifare");
PCSC_Инфо = Новый("AddIn.PCSCInfo");
PCSC_Захват = Новый("AddIn.PCSCCapture");
PCSC_Mifare = Новый("AddIn.PCSCCard_Mifare");
PCSC_Захват.УстановитьATR(ATRКарты);
PCSC_Захват.НачатьЗахват();
Инициализирован = Истина;
Сообщить("Инициализация: классы успешно загружены");
Исключение
ДеинициализацияНажатие(Неопределено);
Сообщить("Инициализация: классы не загружены");
КонецПопытки;
КонецПроцедуры
Процедура ДеинициализацияНажатие(Элемент)
Попытка
PCSC_Захват.ОстановитьЗахват();
Исключение
КонецПопытки;
PCSC_Инфо = Неопределено;
PCSC_Захват = Неопределено;
PCSC_Mifare = Неопределено;
Инициализирован = Ложь;
Сообщить("Деинициализация");
КонецПроцедуры
Процедура ПолучитьСписокРидеровНажатие(Элемент)
Если Инициализирован Тогда
КоличествоРидеров = 0;
ИмяРидера = "";
СпРидеры = Новый СписокЗначений();
Если PCSC_Инфо.ПолучитьCписокРидеров(КоличествоРидеров) = 1 Тогда
Если КоличествоРидеров > 0 Тогда
Для ТекРидер = 0 По КоличествоРидеров - 1 Цикл
Если PCSC_Инфо.ПолучитьИмяРидера(ТекРидер, ИмяРидера) = 1 Тогда
СпРидеры.Добавить(ТекРидер, ИмяРидера);
Сообщить("Обнаружен ридер [" + ТекРидер + "]: " + ИмяРидера);
КонецЕсли;
КонецЦикла;
Иначе
Сообщить("Не один ридер не подключён!");
КонецЕсли;
Иначе
Сообщить("Ошибка при получении списка ридеров");
КонецЕсли;
ЭлементыФормы.НомерРидера.СписокВыбора = СпРидеры;
НомерРидера = 0;
КонецЕсли;
КонецПроцедуры
Процедура ПолучитьТипКартыНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Если PCSC_Mifare.Подключиться() = 1 Тогда
Если PCSC_Mifare.ПолучитьТипКарты(ТипКарты) = 1 Тогда
Если ТипКарты <> CL_CARDTYPE_MIFARE_1K ИЛИ ТипКарты <> CL_CARDTYPE_MIFARE_4K Тогда
Сообщить(ИмяРидера + " - тип карты карты: " + ЭлементыФормы.ТипКарты.СписокВыбора[ТипКарты].Представление);
Иначе
Сообщить(ИмяРидера + " - тип карты карты " + ЭлементыФормы.ТипКарты.СписокВыбора[ТипКарты].Представление + " не поддерживается");
ТипКарты = CL_CARDTYPE_UNKNOWN;
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
PCSC_Mifare.Отключиться();
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ПолучитьUIDКартыНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Если PCSC_Mifare.Подключиться() = 1 Тогда
Если PCSC_Mifare.ПолучитьСерийныйНомер(UIDКарты) = 1 Тогда
Сообщить(ИмяРидера + " - UID карты: " + UIDКарты);
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
PCSC_Mifare.Отключиться();
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЗагрузитьКлючНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
КлючПерем = ?(ТипКлюча = "A", Ключ_A, Ключ_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.ЗагрузитьКлюч(ХранениеКлючаПерем, ТипКлючаПерем, 0, КлючПерем) = 1 Тогда
//Сообщить(ИмяРидера + " - ключ (" + ТипКлюча + ") " + КлючПерем + " загружен");
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Сообщить(ИмяРидера + " - авторизаця блока сектора " + Сектор);
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось загрузить ключ");
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЧтениеDБлокаНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
//PCSC_Mifare.НачатьТранзакцию();
//Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.СчитатьДБлок(Блок) = 1 Тогда
Данные16 = PCSC_Mifare.ОтветКарты;
Сообщить(ИмяРидера + " - чтение блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести чтение блока " + Блок + " сектора " + Сектор);
КонецЕсли;
//Иначе
// Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
//КонецЕсли;
//PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЗаписьDБлокаНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если СтрДлина(Данные16) = 32 И PCSC_Mifare.ЗаписатьДБлок(Блок, Данные16) = 1 Тогда
Сообщить(ИмяРидера + " - запись блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести запись блока " + Блок + " сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЧтениеVБлокаНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.СчитатьВБлок(Блок, ДанныеВ) = 1 Тогда
Сообщить(ИмяРидера + " - чтение блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести чтение блока " + Блок + " сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЗаписьVБлокаНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Адрес = 0;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.ЗаписатьВБлок(Блок, ДанныеВ, Адрес) = 1 Тогда
Сообщить(ИмяРидера + " - запись блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести запись блока " + Блок + " сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ИнкрементНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Адрес = 0;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.Инкремент(Блок, 1) = 1 Тогда
Сообщить(ИмяРидера + " - запись блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести запись блока " + Блок + " сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ДекрементНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Адрес = 0;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.Декремент(Блок, 1) = 1 Тогда
Сообщить(ИмяРидера + " - запись блока " + Блок + " для сектора " + Сектор + " произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести запись блока " + Блок + " сектора " + Сектор);
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура ЧтениеTБлокаНажатие(Элемент)
Если Инициализирован Тогда
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Адрес = 0;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.СчитатьТБлок(Сектор, УДБлок0, УДБлок1,УДБлок2, УДБлок3, Ключ_B) = 1 Тогда
Сообщить(ИмяРидера + " - чтение T-блока произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести чтение T-блока");
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
УсловияДоступаДляБлоков_Заполнить(УДБлок0, УДБлок1, УДБлок2, УДБлок3);
КонецПроцедуры
Процедура ЗаписьTБлокаНажатие(Элемент)
Если Инициализирован Тогда
Если УДБлок3 = 0
ИЛИ УДБлок3 = 2
ИЛИ УДБлок3 = 4
ИЛИ УДБлок3 = 6
ИЛИ УДБлок3 = 7
Тогда
Ответ = Вопрос("При успешной записи будет невозможна модификация условий доступа. Вы хотите продолжить?", РежимДиалогаВопрос.ДаНет);
Если Ответ = КодВозвратаДиалога.Нет Тогда
Возврат;
КонецЕсли;
КонецЕсли;
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Адрес = 0;
ТипКлючаПерем = ?(ТипКлюча = "A", CL_KEYTYPE_MIFARE_A, CL_KEYTYPE_MIFARE_B);
ХранениеКлючаПерем = ?(ХранениеКлюча = VARIANT_TRUE, VARIANT_TRUE, VARIANT_FALSE);
Если PCSC_Mifare.Подключиться() = 1 Тогда
PCSC_Mifare.НачатьТранзакцию();
Если PCSC_Mifare.Аутентификация(Сектор, ХранениеКлючаПерем, ТипКлючаПерем, 0) = 1 Тогда
Если PCSC_Mifare.ЗаписатьТБлок(Сектор, Ключ_A,
Ключ_B,
УДБлок0, УДБлок1, УДБлок2, УДБлок3) = 1
Тогда
Сообщить(ИмяРидера + " - запись T-блока произведено успешно");
Иначе
Сообщить(ИмяРидера + " - не удалось произвести запись T-блока");
КонецЕсли;
Иначе
Сообщить(ИмяРидера + " - не удалось пройти авторизацию для сектора " + Сектор);
КонецЕсли;
PCSC_Mifare.ЗавершитьТранзакцию();
PCSC_Mifare.Отключиться();
Иначе
Сообщить(ИмяРидера + " - не удалось подключится к карте");
КонецЕсли;
КонецЕсли;
УсловияДоступаДляБлоков_Заполнить(УДБлок0, УДБлок1, УДБлок2, УДБлок3);
КонецПроцедуры
Процедура УДБлокПриИзменении(Элемент)
УсловияДоступаДляБлоков_Заполнить(УДБлок0, УДБлок1, УДБлок2, УДБлок3);
КонецПроцедуры
Процедура ПриОткрытии()
УсловияДоступаДляБлоков_Заполнить(УДБлок0, УДБлок1, УДБлок2, УДБлок3);
КонецПроцедуры
Процедура ПриЗакрытии()
ДеинициализацияНажатие(Неопределено);
КонецПроцедуры
Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
Если Источник = "PCSCCapture" Тогда
Если Событие = "КартаЗахвачена" Тогда
КоличествоРидеров = 0;
ИмяРидера = "";
СпРидеры = Новый СписокЗначений();
Если PCSC_Инфо.ПолучитьCписокРидеров(КоличествоРидеров) = 1 Тогда
Если КоличествоРидеров > 0 Тогда
Для ТекРидер = 0 По КоличествоРидеров - 1 Цикл
Если PCSC_Инфо.ПолучитьИмяРидера(ТекРидер, ИмяРидера) = 1 Тогда
СпРидеры.Добавить(ТекРидер, ИмяРидера);
КонецЕсли;
КонецЦикла;
ЭлементыФормы.НомерРидера.СписокВыбора = СпРидеры;
НомерРидера = 0;
Для каждого Номер Из ЭлементыФормы.НомерРидера.СписокВыбора Цикл
Если Номер.Представление = Данные Тогда
НомерРидера = Номер.Значение;
Прервать;
КонецЕсли;
КонецЦикла;
ИмяРидера = ЭлементыФормы.НомерРидера.СписокВыбора[НомерРидера].Представление;
PCSC_Mifare.ИмяРидера = ИмяРидера;
Если PCSC_Mifare.Подключиться() = 1 Тогда
Если PCSC_Mifare.ПолучитьТипКарты(ТипКарты) = 1 Тогда
Если ТипКарты <> CL_CARDTYPE_MIFARE_1K ИЛИ ТипКарты <> CL_CARDTYPE_MIFARE_4K Тогда
Иначе
ТипКарты = CL_CARDTYPE_UNKNOWN;
КонецЕсли;
КонецЕсли;
PCSC_Mifare.ПолучитьСерийныйНомер(UIDКарты);
PCSC_Mifare.Отключиться();
КонецЕсли;
КонецЕсли;
КонецЕсли;
ИначеЕсли Событие = "КартаОсвобождена" Тогда
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Процедура КоманднаяПанельУстановитьДрайвер(Кнопка)
Попытка
ПолучитьМакет("ESDK2_1C_dll").Записать(КаталогПрограммы() + "ESDK2_1C.dll");
ПолучитьМакет("MCSCM_dll").Записать(КаталогПрограммы() + "MCSCM.dll");
ПолучитьМакет("scardsyn_dll").Записать(КаталогПрограммы() + "scardsyn.dll");
ПутьRegSvr32 = "regsvr32.exe " + """" + КаталогПрограммы() + "ESDK2_1C.dll""";
ЗапуститьПриложение(ПутьRegSvr32, , Истина);
Исключение
Сообщить("Ошибка при установки драйвера");
КонецПопытки;
КонецПроцедуры
VARIANT_TRUE = -1;
VARIANT_FALSE = 0;
CL_KEYTYPE_MIFARE_A = 96;
CL_KEYTYPE_MIFARE_B = 97;
CL_CARDTYPE_UNKNOWN = 0;
CL_CARDTYPE_MIFARE_1K = 1;
CL_CARDTYPE_MIFARE_4K = 2;
CL_CARDTYPE_MIFARE_ULTRA_LIGHT = 3;
CL_CARDTYPE_SLE55R_XXXXX = 5;
CL_CARDTYPE_SR176 = 6;
CL_CARDTYPE_SRIX4K = 7;
CL_CARDTYPE_AT88RF020 = 8;
CL_CARDTYPE_AT88SC0204CRF = 9;
CL_CARDTYPE_AT88SC0808CRF = 10;
CL_CARDTYPE_AT88SC1616CRF = 11;
CL_CARDTYPE_AT88SC3216CRF = 12;
CL_CARDTYPE_AT88SC6416CRF = 13;
CL_CARDTYPE_SRF55V10P = 14;
CL_CARDTYPE_SRF55V02P = 15;
CL_CARDTYPE_SRF55V10S = 16;
CL_CARDTYPE_SRF55V02S = 17;
CL_CARDTYPE_TAGIT = 18;
CL_CARDTYPE_LRI512 = 19;
CL_CARDTYPE_ICODESLI = 20;
CL_CARDTYPE_TEMPSENS = 21;
CL_CARDTYPE_ICODE1 = 22;
CL_CARDTYPE_PICOPASS_2K = 23;
CL_CARDTYPE_PICOPASS_2KS = 24;
CL_CARDTYPE_PICOPASS_16K = 25;
CL_CARDTYPE_PICOPASS_16KS = 26;
Инициализирован = Ложь;
ТипКлюча = "A";
ТипКарты = CL_CARDTYPE_UNKNOWN;
ХранениеКлюча = VARIANT_TRUE;
Ключ_A = "FFFFFFFFFFFF";
Ключ_B = "FFFFFFFFFFFF";
ATRКарты = "";
Сектор = 0;
Блок = 0;
УДБлок0 = 0;
УДБлок1 = 0;
УДБлок2 = 0;
УДБлок3 = 0;