Distributed under the terms of the GNU General Public License v2 inher

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
# Distributed under the terms of the GNU General Public License v2
inherit git
DESCRIPTION="Portable and multi-interface IRC client."
HOMEPAGE="http://weechat.flashtux.org/"
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="debug perl python ruby ssl spell lua nls protocols"
if use protocols; then
EGIT_TREE="protocols"
EGIT_BRANCH="protocols"
fi
RDEPEND="sys-libs/ncurses
virtual/libiconv
perl? ( dev-lang/perl )
python? ( virtual/python )
ruby? ( dev-lang/ruby )
lua? ( >=dev-lang/lua-5.0 )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.56
>sys-devel/automake-1.4
nls? ( >=sys-devel/gettext-0.15 )"
# FIXME: what is minimal automake version? 1.4 is known to be unusable
RDEPEND="${DEPEND}"
src_compile() {
if use protocols && use spell; then
ewarn "You are using devel code of Weechat protocols."
ewarn "It is not supporting aspell now, set USE=-spell"
die "USE=protocols is not compatible with USE=spell"
fi
if use nls; then
ewarn "weechat built with USE=-nls MAY have bugs on some systems."
fi
./autogen.sh || die "autogen failed"
# The qt, wxwidgets and gtk frontends are not usable, so they're disabled
econf \
--enable-ncurses \
--disable-qt \
--disable-gtk \
--disable-wxwidgets \
$(use_enable nls) \
$(use_enable perl) \
$(use_enable python) \
$(use_enable ruby) \
$(use_enable lua) \
$(use_enable ssl gnutls) \
$(use_enable spell aspell) \
$(use_with debug debug 2) \
|| die "econf failed"
emake || die "emake failed"
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO || die "dodoc failed"
}