не работает hg serve

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
$ hg serve
192.168.123.1 - - [25/Sep/2008 11:04:54] "GET / HTTP/1.1" 500 -
192.168.123.1 - - [25/Sep/2008 11:04:54] Exception happened during processing request '/':
Traceback (most recent call last):
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/hgweb/server.py", line 68, in do_POST
self.do_write()
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/hgweb/server.py", line 61, in do_write
self.do_hgweb()
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/hgweb/server.py", line 125, in do_hgweb
self.server.application(env, self._start_response)
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/hgweb/hgweb_mod.py", line 148, in __call__
req = wsgirequest(env, respond)
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/hgweb/request.py", line 24, in __init__
self.form = cgi.parse(self.inp, self.env, keep_blank_values=1)
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/demandimport.py", line 74, in __getattribute__
self._load()
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/demandimport.py", line 46, in _load
mod = _origimport(head, globals, locals)
File "build/bdist.linux-i686/egg/cgi/__init__.py", line 52, in <module>
File "/usr/local/stow/mercurial-1.0.2//lib/python2.5/site-packages/mercurial/demandimport.py", line 83, in _demandimport
return _origimport(name, globals, locals, fromlist)
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 2561, in <module>
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 626, in require
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 505, in resolve
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 2379, in parse_requirements
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 1814, in yield_lines
File "/usr/local/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 1813, in yield_lines
TypeError: '_demandmod' object is not iterable