pybabel error

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
pybabel extract -F babel.cfg -k lazy_gettext -o translations/messages.pot .
extracting messages from app.py
extracting messages from config.py
extracting messages from form.py
extracting messages from login_views.py
extracting messages from manage.py
extracting messages from models.py
extracting messages from views.py
extracting messages from instance/config.py
extracting messages from migrations/161170fe476_add_user_model.py
extracting messages from migrations/37973729868_init.py
extracting messages from migrations/4fbdb25ff6b_add_images_and_m2m.py
extracting messages from migrations/56fa92b8f7b_add_images_and_m2m_with_create_all.py
extracting messages from templates/base.html (extensions="jinja2.ext.autoescape,jinja2.ext.with_")
Traceback (most recent call last):
File "/home/ihor/.pyenv/versions/hurtom3-flask/bin/pybabel", line 9, in <module>
load_entry_point('Babel===2.0.dev0-20141225', 'console_scripts', 'pybabel')()
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/frontend.py", line 1151, in main
return CommandLineInterface().run(sys.argv)
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/frontend.py", line 665, in run
return getattr(self, cmdname)(args[1:])
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/frontend.py", line 919, in extract
for filename, lineno, message, comments, context in extracted:
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/extract.py", line 163, in extract_from_dir
strip_comment_tags):
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/extract.py", line 190, in extract_from_file
strip_comment_tags))
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/babel/messages/extract.py", line 249, in extract
func = entry_point.load(require=True)
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/pkg_resources.py", line 2252, in load
self.require(env, installer)
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/pkg_resources.py", line 2266, in require
items = working_set.resolve(reqs, env, installer)
File "/home/ihor/.pyenv/versions/hurtom3-flask/lib/python3.4/site-packages/pkg_resources.py", line 761, in resolve
raise VersionConflict(tmpl % args)
pkg_resources.VersionConflict: Babel 2.0.dev0-20141225 is installed but Babel>=0.8 is required by []