Функция ПечататьЧек Объект Пароль СписокТоваров СуммаЧека Получено Ски

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, НомерСекции, НомерЧека, ДлинаСтроки,ИннПродавца)
// Если ПустоеЗначение(Объект) = 1 Тогда
// ОписаниеРезультата = "устройство не подключено";
// Возврат 0;
// ИначеЕсли ПодключитьсяКФР(Объект) = 0 Тогда
// Возврат 0;
// КонецЕсли;
//
// //Объект.Mode = 1; // режим регистрации чеков
// Объект.Password = Пароль;// пароль на режим регистрации
// //Объект.SetMode();
// //Объект.GetStatus();
// Объект.TaxType = ТипНалогов;
//
// //Если Объект.СостояниеЧека <> 0 Тогда
// // Попытка
// // Объект.CancelCheck();
// // Исключение
// // КонецПопытки;
// //КонецЕсли;
// //
// //Если Объект.Результат <> 0 Тогда
// // Попытка
// // Объект.CancelCheck();
// // Исключение
// // КонецПопытки;
// // ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
// // ОтключитьсяОтФР(Объект, 0);
// // Возврат 0;
// //КонецЕсли;
//
// // регистрация товаров
// РезРегистрация = 1;
// СписокТоваров.ВыбратьСтроки();
//
// ДлинаНаименования =48;//Объект.ДлинаСтрокиСимволов; // зависит от модели ФР
// Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
// //СтрокаДляПечати = СписокТоваров.ТовНаим;
// //Объект.Password = Пароль;
// //Объект.StringForPrinting = Лев(СтрокаДляПечати,48);
//
//
//
//
// //Проверка наличия колонки "НДС" в таблице значений.
// НДСЕсть = "";
// Попытка
// НДС = СписокТоваров.НДС;
// НДСЕсть = 1;
// Исключение
// НДСЕсть = 0;
// КонецПопытки;
//
// //Если НДСЕсть = 1 Тогда
// // Объект.Name = "";
// //Иначе
// // Объект.Name = Лев(СписокТоваров.ТовНаим, ДлинаНаименования);
// //КонецЕсли;
// СтрокаДляПечати = СписокТоваров.ТовНаим;
// Объект.Password = Пароль;
// Объект.StringForPrinting = Лев(СтрокаДляПечати,48);
//
// Объект.Price = Окр(СписокТоваров.Цена,2,1);
// Объект.Quantity = СписокТоваров.Количество;
//
// Если ПризнВозврата = 0 Тогда
//
// Если НДСЕсть = 1 Тогда//Печатаем НДС
//
// // В настройках ФР надо настроить ставки:
// // Налог 1 = 18% - НДС 18%
// // Налог 2 = 10% - НДС 10%
// // Налог 3 = 20% - НДС 20%
// // Налог 4 = 0% - без НДС
// // и Тип налога = 2 (Налог на каждую продажу)
//
// Если СписокТоваров.НДС = 18 Тогда
// Объект.Department = 1;
// ИначеЕсли СписокТоваров.НДС = 10 Тогда
// Объект.Department = 2;
// ИначеЕсли СписокТоваров.НДС = 20 Тогда
// Объект.Department = 3;
// Иначе
// Объект.Department = 4;
// КонецЕсли;
// Иначе
// Объект.Department = 4;
// КонецЕсли;
//
// //Если ПризнВозврата = 0 Тогда
// Объект.Sale();
// Иначе
// Объект.ReturnSale();
// КонецЕсли;
//
// Если Объект.Результат <> 0 Тогда
// ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
// Попытка
// Объект.CancelCheck();
// Исключение
// КонецПопытки;
// ОтключитьсяОтФР(Объект, 0);
// Возврат 0;
// КонецЕсли;
//
// Если НДСЕсть = 1 Тогда
// СтрокаДляПечати = СписокТоваров.ТовНаим;
// Пока СтрДлина(СтрокаДляПечати)>0 Цикл
// Объект.Caption = Лев(СтрокаДляПечати,ДлинаНаименования);
// Объект.PrintString();
// СтрокаДляПечати = СокрЛП(Сред(СтрокаДляПечати,ДлинаНаименования+1));
// КонецЦикла;
// КонецЕсли;
//
// Если Объект.Результат <> 0 Тогда
// ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
// Попытка
// Объект.CancelCheck();
// Исключение
// КонецПопытки;
// ОтключитьсяОтФР(Объект, 0);
// Возврат 0;
// КонецЕсли;
//
// КонецЦикла;
//
// Если ПустоеЗначение(Скидка) = 0 Тогда
// Если Скидка < 0 Тогда
// // надбавка
// Объект.Percents = -Скидка;
// Объект.ПроцентнаяНадбавка();
// Иначе
// // Скидка
// Объект.Percents = Скидка;
// Объект.ПроцентнаяСкидка();
// КонецЕсли;
//
// КонецЕсли;
//
// Если Объект.Результат <> 0 Тогда
// Объект.Percents = 0;
// ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
// Попытка
// Объект.CancelCheck();
// Исключение
// КонецПопытки;
// ОтключитьсяОтФР(Объект, 0);
// Возврат 0;
// КонецЕсли;
//
// Объект.Department = НомерСекции;
//
// НомерЧека = Объект.НомерЧека;
// Объект.Summ1 = Окр(Получено, 2, 1);
//
// Объект.FNCloseCheckEx();
//
// Объект.ЗакрытьЧек();
//
//
// //Если (Получено > 0) И (Получено > СуммаЧека) Тогда
// // Объект.Summ = Окр(Получено, 2, 1);
// // Объект.ОплатаСоСдачей();
// //Иначе
// // Объект.FNCloseCheckEx();
// //
// // Объект.ЗакрытьЧек();
// //КонецЕсли;
//
// Если Объект.Результат <> 0 Тогда
// ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
// Попытка
// Объект.CancelCheck();
// Исключение
// КонецПопытки;
// ОтключитьсяОтФР(Объект, 0);
// Возврат 0;
// КонецЕсли;
//
// Возврат ОтключитьсяОтФР(Объект);
//Если ПустоеЗначение(Объект) = 1 Тогда
// ОписаниеРезультата = "устройство не подключено";
// Возврат 0;
//ИначеЕсли ПодключитьсяКФР(Объект, Пароль) = 0 Тогда
// Возврат 0;
//КонецЕсли;
// регистрация товаров
КорректноКудаОтправитьЧек = -1//-1 не ввден, 1- корректно,0 не корректно
Если ПустоеЗначение(КудаОтправитьЧек) = 0 Тогда
Если Найти(СокрЛП(КудаОтправитьЧек),"@") <> 0 Тогда
КорректноКудаОтправитьЧек = 1;
ИначеЕсли Лев(СокрЛП(КудаОтправитьЧек),2) = "+7" Тогда
КорректноКудаОтправитьЧек = 1;
Иначе
КорректноКудаОтправитьЧек = 0;
Если Вопрос("Не корректно введен email или номер телефона клиента, пробить обычный чек?",4) = 6 Тогда
КорректноКудаОтправитьЧек = -1;
Иначе
Предупреждение("Проверте email или номер телефона клиента, номер телефона должен начинаться на +7");
Возврат 0;
КонецЕсли;
КонецЕсли;
КонецЕсли;
Объект.TaxType = ТипНалогов;
РезРегистрация = 1;
// СписокТоваров.ВыбратьСтроки();
Получено1 = 0;
// Если СуммаСкидки <> 0 Тогда
// СуммаВсего1 = СписокТоваров.Итог("Сумма");
// СписокТоваров.ВыбратьСтроки();
// Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
// СписокТоваров.Сумма = СписокТоваров.Сумма - СписокТоваров.Сумма/СуммаВсего1*100 * СуммаСкидки/100;
// КонецЦикла;
// КонецЕсли;
//
СуммаСкидкиНаЧек = СписокТоваров.Итог("СуммаСкидки");
Если СокрЛП(ИННПродавца) <> "" Тогда
Объект.TagNumber = 1203;
Объект.TagType = 7;
Объект.TagValueStr = СокрЛП(ИННПродавца);
Объект.FNSendTag();
КонецЕсли;
// СписокТоваров.НоваяКолонка("ПолнСумма","Число",15,2);
// СписокТоваров.НоваяКолонка("СуммаСкидки","Число",15,2);
//
//
//
// СписокТоваров.ВыбратьСтроки();
//
// Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
// СписокТоваров.ПолнСумма = СписокТоваров.Цена*СписокТоваров.Количество;
// СписокТоваров.СуммаСкидки = СписокТоваров.ПолнСумма-СписокТоваров.Сумма;
//
// КонецЦикла;
СписокТоваров.ВыбратьСтроки();
Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
СтрокаДляПечати = СписокТоваров.ТовНаим;
Объект.Password = Пароль;
Объект.StringForPrinting = Лев(СтрокаДляПечати,48);
Если СписокТоваров.СуммаСкидки = 0 Тогда
//ЦенаЦены = СписокТоваров.Цена;
Объект.Price = СписокТоваров.Цена;
Получено1 = Получено1+ СписокТоваров.Цена * СписокТоваров.Количество;
Иначе
//СуммаСкидкиНаЧек =СуммаСкидкиНаЧек +(СписокТоваров.Цена * СписокТоваров.Количество - СписокТоваров.Сумма);
//ЦенаЦены = СписокТоваров.Сумма/СписокТоваров.Количество;
//ЦенаЦены =Окр(СписокТоваров.Сумма/СписокТоваров.Количество,2);
Объект.Price = СписокТоваров.Сумма/СписокТоваров.Количество;
Получено1 = Получено1+ СписокТоваров.Сумма/СписокТоваров.Количество;;
КонецЕсли;
//Объект.Price = СписокТоваров.Цена;
Объект.Quantity = СписокТоваров.Количество;
Объект.Department = НомерСекции;
//Объект.DiscountValue = Скидка;
//Объект.FNDiscountOperation();
//Объект.FNOperation();
//Проверка наличия колонки "НДС" в таблице значений.
НДСЕсть = "";
Попытка
НДС = СписокТоваров.НДС;
НДСЕсть = 1;
Исключение
НДСЕсть = 0;
КонецПопытки;
Если НДСЕсть = 1 Тогд�//Печатаем НДС
// В настройках ФР надо настроить ставки:
// Налог 1 = 18% - НДС 18%
// Налог 2 = 10% - НДС 10%
// Налог 3 = 20% - НДС 20%
Если СписокТоваров.НДС = 18 Тогда
Объект.Tax1 = 1;
ИначеЕсли СписокТоваров.НДС = 10 Тогда
Объект.Tax1 = 2;
ИначеЕсли СписокТоваров.НДС = 20 Тогда
Объект.Tax1 = 3;
Иначе
Объект.Tax1 = 0;
КонецЕсли;
Объект.Tax2 = 0;
Объект.Tax3 = 0;
Объект.Tax4 = 0;
ДлинаСтроки = 36;
Иначе
ДлинаСтроки = 0;
КонецЕсли;
Если ПризнВозврата = 0 Тогда
Объект.Sale();
Иначе
Объект.ReturnSale();
КонецЕсли;
// СтрокаДляПечати = СписокТоваров.ТовНаим;
//
//
// Если ПустоеЗначение(ДлинаСтроки) = 1 Тогда
// Объект.StringForPrinting = СтрокаДляПечати;
// //Объект.FNOperation();
//
// Объект.PrintString();
//
// Иначе
// Пока СтрДлина(СтрокаДляПечати)>0 Цикл
// Объект.StringForPrinting = Лев(СтрокаДляПечати,ДлинаСтроки);
// //Объект.FNOperation();
//
// Объект.PrintString();
// СтрокаДляПечати = СокрЛП(Сред(СтрокаДляПечати,ДлинаСтроки+1));
// КонецЦикла;
// КонецЕсли;
Если Объект.ResultCode <> 0 Тогда
ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
АннулированиеЧека(Объект, Пароль);
//ОтключитьсяОтФР(Объект, Пароль, 0);
Возврат 0;
КонецЕсли;
КонецЦикла;
Если константа.ПисатьСуммуСкидкиВЧеке = 1 тогда
СтрокаДляПечати = "Сумма скидки на чек:" + Строка(глФРМ(СуммаСкидкиНаЧек));
Объект.Password = Пароль;
Объект.StringForPrinting = Лев(СтрокаДляПечати,48);
Иначе
СтрокаДляПечати = "__________________________";//+ Строка(глФРМ(СуммаСкидки,Валюта,1));
Объект.Password = Пароль;
Объект.StringForPrinting = Лев(СтрокаДляПечати,48);
КонецЕсли;
Объект.Password = Пароль;
Если ПустоеЗначение(ВидОплаты) = 0 Тогда
Если ВидОплаты = перечисление.ВидыОплаты.Наличными тогда
Если (Получено = 0) или (Получено <Получено1) Тогда
Объект.Summ1 = Получено1;
Объект.Summ2 = 0;
Иначе
Объект.Summ1 = Получено;
Объект.Summ2 = 0;
КонецЕсли;
Иначе
Объект.Summ1 = 0;
Объект.Summ2 = Получено1;
//
//
КонецЕсли;
Иначе
Объект.Summ1 = Получено1;
Объект.Summ2 = 0;
КонецЕсли;
//Объект.Summ2 = 0;
Объект.Summ3 = 0;
Объект.Summ4 = 0;
//Объект.StringForPrinting="Масло";
//Объект.DiscountOnCheck=Скидка;
//Объект.FNOperation();
Если ПустоеЗначение(КудаОтправитьЧек) = 0 Тогда
Объект.CustomerEmail = СокрЛП(КудаОтправитьЧек);
Объект.FNSendCustomerEmail();
КонецЕсли;
Объект.FNCloseCheckEx();
//Объект.CloseCheck();
Если Объект.ResultCode <> 0 Тогда
//Сообщить(Объект.ResultCode);
ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
АннулированиеЧека(Объект, Пароль);
//ОтключитьсяОтФР(Объект, Пароль, 0);
Возврат 0;
КонецЕсли;
Объект.Password = Пароль;
Объект.GetECRStatus();
Если Объект.ResultCode <> 0 Тогда
ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
//ОтключитьсяОтФР(Объект, Пароль, 0);
Возврат 0;
КонецЕсли;
НомерЧека = Объект.OpenDocumentNumber+?(Объект.ECRAdvancedMode=5,1,0);
Возврат ОтключитьсяОтФР(Объект, Пароль);
КонецФункции