php Выше этой строки файле ничего не должно быть include_once data php

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
<?php /* Выше этой строки в файле ничего не должно быть */
include_once ('./data/php_pages/plugin_bueditor.php');/* Для удаления плагина 'BUEditor' - удалите эту строку */
# Все используемые шаблоном дизайна переменные обязательно надо объявить глобальными:
global
$_s, # Это все настройки блога
$title, # Тайтл документа.
$echo, # Контент документа
$add, # Колонка рекламы
$calendula, # Код календарика
$menu, # Менюшка блога
$topmenu, # Верхняя менюшка навигации
$blogtitle, # Название блога
$turl, # URL морды блога.
$counters, # Счётчики
$time_start; # Время исполнения скрипта
# Оформление меню и заголовков специфичное для ЭТОЙ версии дизайна, начало:
$n=extract(
preg_replace(
array(
'/<li><a([^>]+)>([^<]+)<\/a><\/li>/i',
'/<li class="nolink">(.+)<\/li>/i',
),
array(
'<li><a\\1><b>\\2</b></a></li>',
'<li class="nolink"><em><em>\\1</em></em></li>',
),
compact('topmenu','menu','add','counters')
),
EXTR_OVERWRITE);