НаКлиенте Процедура ПродукцияМассаНеттоП риИзменении Элемент ТекущиеДа

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
&НаКлиенте
Процедура ПродукцияМассаНеттоПриИзменении(Элемент)
ТекущиеДанные = Элементы.Продукция.ТекущиеДанные;
Если ЗначениеЗаполнено(ТекущиеДанные.МассаНетто) И (ТекущиеДанные.Емкость > 0) Тогда
пКоличество = Цел(ТекущиеДанные.МассаНетто / ТекущиеДанные.Емкость);
пМассаНетто = Окр(пКоличество * ТекущиеДанные.Емкость, 1);
Если ТекущиеДанные.МассаНетто = пМассаНетто Тогда
ТекущиеДанные.Количество = пКоличество;
Иначе
ТекущиеДанные.Количество = пКоличество + 1;
Отказ = Ложь;
ЭлементМН = "Продукция[" + Элементы.Продукция.ТекущаяСтрока + "].МассаНетто";
ТекстСообщения = "Последняя единица тары заполнена неполностью продукцией!";
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения,, ЭлементМН, "Объект", Отказ);
КонецЕсли;
КонецЕсли;
КонецПроцедуры