root nembook aptitude purge samba samba-common Reading package lists D

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
root@nembook:~# aptitude purge samba samba-common
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages have been kept back:
fuse-utils gxneur libfuse-dev libfuse2 libntfs-3g-dev libxnconfig7 linux-image-2.6-686 ntfs-3g xneur zim
The following packages will be REMOVED:
samba{p} samba-common{p}
0 packages upgraded, 0 newly installed, 2 to remove and 10 not upgraded.
Need to get 0B of archives. After unpacking 13.7MB will be freed.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
(Reading database ... 130981 files and directories currently installed.)
Removing samba ...
invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
dpkg: error processing samba (--purge):
subprocess pre-removal script returned error exit status 102
dpkg: samba-common: dependency problems, but removing anyway as you request:
samba depends on samba-common (= 3.0.24-6etch4).
Removing samba-common ...
Purging configuration files for samba-common ...
dpkg - warning: while removing samba-common, directory `/var/log/samba' not empty so not removed.
Errors were encountered while processing:
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
root@nembook:~# aptitude upgrade
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages have unmet dependencies:
samba: Depends: samba-common (= 3.0.24-6etch4) but it is not installable