From 447c816cdff0d7141356 454ffa2cf6f616441324 Mon Sep 17 00 00 00 200

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
From 447c816cdff0d7141356454ffa2cf6f616441324 Mon Sep 17 00:00:00 2001
From: Konstantin Pavlov <thresh@altlinux.org>
Date: Wed, 29 Jul 2009 13:38:07 +0400
Subject: [PATCH 1/2] Add configure.ac detection of libva, default disabled.
This enables building avcodec plugin with VAAPI support.
---
configure.ac | 23 +++++++++++++++++++++++
1 files changed, 23 insertions(+), 0 deletions(-)
diff --git a/configure.ac b/configure.ac
index 8d974df..c12613d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2934,6 +2934,29 @@ then
fi
dnl
+dnl libva needs avcodec
+dnl
+AC_ARG_ENABLE(libva,
+ [ --enable-libva libva VAAPI support (default disabled)])
+if test "${enable_libva}" = "yes"
+then
+ if test "x${have_avcodec}" = "xyes"
+ then
+ PKG_CHECK_MODULES(LIBVA, [libva >= 0.31.0 libva-x11 >= 0.31.0],
+ [
+ VLC_ADD_LIBS([avcodec],[$LIBVA_LIBS])
+ VLC_ADD_CFLAGS([avcodec],[$LIBVA_CFLAGS])
+ AC_DEFINE(HAVE_AVCODEC_VAAPI, 1, [Define if avcodec has to be built with VAAPI support.])
+ ],[
+ AC_MSG_ERROR([No libva => 0.31.0 found, building avcodec plugin without VAAPI support.])
+ ]
+ )
+ else
+ AC_MSG_ERROR([libva VAAPI support depends on avcodec])
+ fi
+fi
+
+dnl
dnl stream_out switcher needs libavcodec
dnl
AC_ARG_ENABLE(switcher,
--
1.6.4.4