widget home vsrede vsrede jinja datastructure py 233 RuntimeWarning Py

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
[********** widget]$ /home/vsrede/vsrede/jinja/datastructure.py:233: RuntimeWarning: Python C API version mismatch for module _speedups: This Python has API version 1013, module _speedups has version 1012.
from jinja._speedups import BaseContext
Traceback (most recent call last):
File "/home/lorien/widget/frontend.py", line 9, in <module>
import simplejson
File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 113, in <module>
File "build/bdist.linux-i686/egg/simplejson/encoder.py", line 6, in <module>
File "build/bdist.linux-i686/egg/simplejson/_speedups.py", line 7, in <module>
File "build/bdist.linux-i686/egg/simplejson/_speedups.py", line 4, in __bootstrap__
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 841, in resource_filename
self, resource_name
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1310, in get_resource_filename
self._extract_resource(manager, self._eager_to_zip(name))
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1332, in _extract_resource
self.egg_name, self._parts(zip_path)
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 921, in get_cache_path
self.extraction_error()
File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 887, in extraction_error
raise err
pkg_resources.ExtractionError: Can't extract file(s) to egg cache
The following error occurred while trying to extract file(s) to the Python egg
cache:
[Errno 13] Permission denied: '/srv/www/lighttpd/.python-eggs'
The Python egg cache directory is currently set to:
/srv/www/lighttpd/.python-eggs
Perhaps your account does not have write access to this directory? You can
change the cache directory by setting the PYTHON_EGG_CACHE environment
variable to point to an accessible directory.